Synology Failed to establish IEEE 802.3ad connection Cisco

Download PDF

Cisco_logo_2006       logo-Synology-300x300

 

 

Failed to establish IEEE 802.3ad connection

Failed to establish IEEE 802.3ad connection

Configuring Synology Link Aggregation

I am using Synology RS814+ and Cisco Catalyst 3750G. RS814+ has 4 gigabit ports. In my case I have only used first 2 ports to create an aggregation link.

If you wish to create 2 and 2 links, then make sure to create interface Port-channel2 for second link and use channel-group2 mode active on switch interfaces.

This configuration works 100%, please let me know if any problems.

interface Port-channel1
switchport
switchport access vlan 100
switchport mode access

interface GigabitEthernet1/0/1
description “Synology NIC1”
switchport access vlan 100
switchport mode access
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet1/0/2
description “Synology NIC2”
switchport access vlan 100
switchport mode access
channel-protocol lacp
channel-group 1 mode active

How to fix: Hotmail & Gmail mark me as SPAM – Be careful! This sender failed our fraud detection checks.

Download PDF

If your emails keep going to people’s “Junk” or “Spam” folders on either GMAIL or HOTMAIL this is how to fix it:

GMAIL, HOTMAIL and many other public email systems use Sender Policy Framework (SPF) to recognize legit senders.

If you do not have a valid SPF Record in place, your emails won’t pass the security check and will me marked as SPAM.

 

1. You need to access your Hosting Control Panel, where the domain in question is hosted. In our case we use cPanel.

cpanel

2. Find DNS Zone Editor icon (either Simple or Advanced)

dns_editor

3. Chose the domain you want to add the records to and add the following details

add_txt_record

 

v=spf1 ip4:ipaddress/24 -all

v=spf1 a mx include:serverhostname.com ~all

v=spf1 +a +mx +ip4:ipaddress ?all

 

First option is to use the public ip address /24 in that subnet

Second option uses the server FQDN no matter what the IP is

Third option uses the public ip address regardles of subnets

 

Second option us usually the most correct option since it uses a FQDN regardles of it’s public IP address..

 

Hope this helps 🙂

If any questions feel free to comment or private message me.

 

 UPDATE 04.10.2013.

SPF Record Generator

By Microsoft, works great.

 

Mac OS X Remove SSH Known Host

Download PDF

If you are getting this error while trying to SSH into a machine using the same name or the same IP address that was already used for SSH, you will get an error bellow:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
5c:9b:16:56:a6:cd:11:10:3a:cd:1b:a2:91:cd:e5:1c.
Please contact your system administrator.
Add correct host key in /Users/user/.ssh/known_hosts to get rid of this message.
Offending key in /Users/user/.ssh/known_hosts:1
RSA host key for server1.example.com has changed and you have requested strict checking.
Host key verification failed.

How do I fix this problem under Mac OX X?

You need to run the following command to get rid of this problem. Open the terminal and type the following command: (one of them)

ssh-keygen -R server-name
ssh-keygen -R server.ip.addre.ss
ssh-keygen -R 202.54.1.5
ssh-keygen -R server1.example.com

for example:   ssh-keygen -R 192.168.0.100
or: ssh-keygen -R centos.local

How to test SMTP operations using Telnet

Download PDF

1. Telnet into Exchange server hosting IMS service using TCP port 25.
Command is telnet <servername> 25

2. Turn on local echo on your telnet client so that you can see what you are typing.
On Win 9x and NT 3.5/4.0 Telnet client this done by selecting the “preferences” from the “terminal” pull down menu, and checking the local echo radio button.  For Windows 2000 telnet client, issue command “set local_echo”, from the telnet command prompt.

3. Issue the following smtp command sequence

helo <your domain name><enter>                  
response should be as follows
250 OK

mail from: <your Email Address><enter>
response should be as follows
250 OK – mail from <your Email address>

rcpt to: <recipient address><enter>
response should be as follows
250 OK – Recipient <recipient address>

data<enter>
response should be as follows
354 Send data.  End with CRLF.CRLF

To: <recipient’s display name><enter>
From: <your display name><enter>
Subject: <Subject field of Email message><enter>
<Enter you body text><enter><enter> . <enter>

response should be as follows
250 OK

quit<enter>

More detailed link on Microsoft website. http://support.microsoft.com/kb/153119

How to open files from unknown developers without a warning in OSX?

Download PDF

You can disable Gatekeeper in System Preferences:

aW8wW

This removes the warnings about opening files downloaded from the internet:

defaults write com.apple.LaunchServices LSQuarantine -bool false

It doesn’t affect the dialogs about opening applications for the first time though.

You can run Finder as root with osascript -e 'quit app "Finder"' && sudo /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder, but it’s not really meant to be done permanently.